İçeriğe geç

Temel (Cisco) Switch Yapılandırması

Bu gün büyük küçük organizasyonlar farketmeksizin bir switch’in
*temel seviyede işlevsellik,
*temel seviyede yönetilebilirlik ve
*temel seviyede de güvenlik konfigürasyonunu yapacağız.

Adımlarımız şu şekilde olacak,
– Hostname gireceğiz, VTP mode transparent olarak ayarlayacağız. Kullanacağımız tüm vlanları Layer2 olarak oluşturacağız ve portlara atayacağız.
-Management için Layer 3 bir interface oluşturup ip adresi vereceğiz. Default gateway yazacağız.
– Local userlar oluşturup secret parolalar oluşturacağız. SSH için cyrpto key oluşturacağız ve VTY linelarını ayarlacağız.

Başlıyoruz !

Ben Cisco Packet Tracer kullanacağım. Bu uygulamamızda gerçek cihaz ile Packet Tracer arasında bir fark olmayacaktır.

Örneğimizi Cisco WS-C2960-24TT bir switch üzerinden işleyeceğiz.

en diyerek privelege moda geçiyoruz
conf t diyerek konfigürasyon moduna geçiyoruz
hostanme SW1 diyerek SW1 hostname veriyoruz.

Şimdi VTP modunu transparent olarak ayarlıyoruz ki yanlış konfigürasyonu yapılmış olan diğer switchlerdeki vlanları uçurmayalım 🙂

vtp mode transparent

Şimdi kullanacağımız vlanları oluşturuyoruz. Örneğimizde vlan 10, vlan 20 vlan 30 ve management için vlan 88 kullanacağız. “Vlan 88 10.0.88.0/24” networkü olsun diyoruz.
vlanlarımızı oluşturuyoruz

vlan 10
vlan 20
vlan 30
vlan 88

Management vlanımız olan vlan 88’i için Layer 3 bir interface oluşturup ip adresi ataması yapıyoruz.

interface vlan 88
ip address 10.0.88.41 255.255.255.0

şimdi farklı networklerden bu switche ulaşabilmek için bir gateway atıyoruz.
exitdiyerek interface’den çıkıyoruz
ip default-gateway 10.0.88.1

Oluşturduğumuz vlanları kullanacağımız portları sırayla,
fa0/1 ->vlan 10,
fa0/2 -> vlan 20,
fa0/3 -> vlan 30, olarak atıyoruz ve diğer networklere bağlanan uplink portumuzu gi0/1 kabul ediyoruz.
gi0/1 – > trunk olarak ayarlıyoruz.

interface fa0/1
switchport access vlan 10
interface fa0/2
switchport access vlan 20
interface fa0/3
switchport access vlan 30
interface gi0/1
switchport mode trunk

Aslında sadece buradaki konfigürasyon bir switchin çalışması için yeterli. Switchin tek yapması gereken hareket vlan etiketli frame’leri ilgili portlara yönlendirmesi.

Şimdi switch’e bağlanacağımız userlarımızı oluşturuyoruz.

exit
username ozgur privilege 15 secret ozgur123 -> privilege 15 user’ımızın yetkisi ozgur123 parolası 🙂

şimdi ssh için crypto key üreteceğiz ama öncesinde bir domain-name vermemiz gerekiyor. Internet ortamında olmayan domain-name’ler kullanmanızı tavsiye ediyorum.
ip domain-name ozgurbilgi.local

crypto key generate rsa general-keys modulus 1024

Evet ssh aktif oldu. şimdi VTY line’larını ayarlarak işi bitiriyoruz.

vty 0 15 -> tüm vty linelerı için seçiyoruz.
transport input ssh -> gelen istekleri ssh’a aktarıyoruz.
login local -> local user’larla login olabileceğimizi belirtiyoruz.

end
wr
konfigürasyonumuzu kaydedip işi bitiriyoruz.

SSH testi 😉


Tüm konfigürasyon çıkıtısı bu dosyadadır.

Teşekkürler.

Tarih:GenelNetworkSwitching

İlk Yorumu Siz Yapın

Bir cevap yazın

E-posta hesabınız yayımlanmayacak. Gerekli alanlar * ile işaretlenmişlerdir